Important Notice to Customers on Accpac ERP Version 5.5

As of January 31, 2013, Sage will no longer support updates to version 5.5.  this will be particularly important to you as Payroll Updates will no longer be provided for this version.  Please contact us immediately to begin planning an upgrade.

Leave A Comment...

*